Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 14, 2024 - 10:00 UTC
Scheduled
Dear Client,
We will be performing a number of changes to the search API in order to ensure consistency with the rest of the API and introduce further value to the platform. All changes are outlined below and are scheduled to be released on Monday October 14th at 10:00 UTC.
If you have any questions about these changes or believe they would negatively impact you please get in contact with the Client Success team as soon as possible.
Response changes 1. All field names will update from snake_case to camelCase 2. Field name change from guid to id 3. Remove the 'musicube_' prefix from all genre field names and their corresponding tagstrengths 4. Remove the fields track_type, instrumental, primary_sound_character, production_rating, song_rating, performance_rating, curateability plus their corresponding values in tagstrengths, language_of_performance 5. Add additional fields of useCase, industrySuitability, channelSuitability
Request Changes: 1. Query parameter change from licensor_ids to licensorIds
Response Changes: 1. Field name change from size to pageSize 2. Field name change from seven_digital_id to id 3. Name objects in the result array, changing from "result": [ {… to "result": [ "track": {... 4. Introduce a release object which includes release_id and release_title. This will display as follow:, "release": { "id": 12134, "title": "The Pop Hits"} 5. Field response name change removing 7d-artist- from the field id in the artist element
Request Changes: 1. All field names will update from snake_case to camelCase
Response Changes: 1. Field name change from size to pageSize 2. Name objects in the result array, changing from "result": [ {… to "result": [ "track": {...
Request Changes: 1. Query parameter change from licensor_ids to licensorIds
Response Changes: 1. Field name change from size to pageSize 2. Field name change from seven_digital_id to id 3. Name objects in the result array, changing from "result": [ {… to "result": [ "track": {... 4. Remove the fields release_id and release_title at track level as they're already contained within the release object
Request Changes: 1. Query parameter change from licensor_ids to licensorIds
Response Changes: 1. Field name change from size to pageSize 2. Field response name change removing 7d-artist- from the field id in the artist element 3. Name objects in the result array, changing from "result": [ {… to "result": [ "artist": {...
Posted Sep 30, 2024 - 15:34 UTC
This scheduled maintenance affected: API (Catalogue Search).